pip install pymongo with xcode 4

xcode 4 kills PPC support. in other words, xcode 4 breaks pip install [stuff] if stuff tries to compile for PPC

do this to fix it: env ARCHFLAGS='-arch i386 -arch x86_64' [pip install command]

e.g. env ARCHFLAGS='-arch i386 -arch x86_64' pip install pymongo

or e.g. env ARCHFLAGS='-arch i386 -arch x86_64' pip install http://pypi.python.org/packages/source/n/nltk/nltk-2.0.1rc1.tar.gz